2010 Rapide engine "sputtering" - Aston Martin Forum

Go Back   Aston Martin Forum > Aston Martin Forum > The New Era

Reply
 
Thread Tools Display Modes
  #1  
Old 02-08-2020, 01:56 AM
RapideRxD RapideRxD is online now
Junior Member
 
Join Date: Feb 2020
Posts: 1
RapideRxD is on a distinguished road
Question 2010 Rapide engine "sputtering"

Hi all,
Just picked this stunning Concourse Blue beauty up with less than 20k miles. On my way home a few nights ago, and ever since, every time I get on it, either a little or a lot, it starts sputtering, almost like it misfiring. Power is down a little, but most of all, it is annoying. It doesn't SEEM to do it at a gentle cruise speed, but can be felt even at an idle. I'm thinking it's electical...coil, spark plug or wire, etc. Need some help with this.

Second question...has anyone installed any type of backup camera system on this car? If so, brand, approx. cost, pros / cons, etc.

Other than that, I'm over the moon with the Rapide..people in Ferraris and Bentleys are asking what it is and how I like it...feel like a movie star.

Thanks for the add to the forum and the advice in advance,
Jerry
Reply With Quote
Sponsor - Register now for free to stop viewing this ad.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 02:51 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.