Aston Martin Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
On start up often my abs and limited slip lights will stay off, after a few miles they both come on. They seem to be linked in some way, both will be eather on or off.
Any ideas? And Merry Christmas. Michael
 

·
Registered
Joined
·
97 Posts
You will be able to get a instant diagnosis If you scan the ABS with an OBD II scanner that is capable of doing that, it will deliver a fault code that will direct you to where the problem lies.

Innova scanners capable of doing that are are now iavailable in the $150-$200 range and would save you a lot of time.

If not, its trial and error, I would inspect and clean the Wheel Speed Sensors first (they are magnetic and get iron filings from the brake rotors build up on them)and make sure the wheel bearings and reluctor rings are in good shape, as excess play in a wheel bearing or a loose or rusted up reluctor ring will cause a fault code and ABS/Trac disablement.,lack of electrical continuity to the sensors (wire breaks or connectors corroded)can also cause problems.

Problems with the ABS unit itself with the circuit board or motor usually result in a instant ABS/Trac fault on startup so I doubt your problem lies there.

Wayne
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #4 ·
I bought an Innova 3100 with ABS, good advice, I can use it on my other cars. BUT I can not see where to plug it in on the Aston . I know, rt.side side pannel, I have had it off and see no way to do that. What am I missing?
Michael
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top